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Choosing options that affect all of OO0

This section covers some of the settings that apply to all the
components of OO0 and are particularly important when using Writer.
Other general options are discussed in Chapter 2 (Setting Up
OpenOffice.org) in the Getting Started guide.

Click Tools > Options. The list on the left-hand side of the Options -
OpenOffice.org dialog box varies depending on which component of
OOo is open. The illustrations in this chapter show the list as it appears
when a Writer document is open.

Click the + sign by OpenOffice.org on the left-hand side. A list of pages
drops down. Selecting an item in the list causes the right-hand side of
the dialog box to display the relevant page.

Options - Open{Office.crg h

= ] 0
User Data ;
General a
Mermory
View
Print
Paths
Colours
Fonts
Security
Appearance
Accessibility
lava
Irnprovernent Program

Figure 1: OpenOffice.org options

The Back button has the same effect on all pages of the
Note Options dialog box. It resets options to the values that were in
place when you opened OOo.

User Data options

Because Writer uses the name or initials stored in the OpenOffice.org -
User Data page for several things, including document properties
(created by and last edited by information) and the name of the author
of notes and changes, you will want to ensure that the correct
information appears here.

Fill in the form (shown in Figure 2) or amend or delete any existing
incorrect information.
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Address
Company
Forename,Surname fInitials Peter Hillier-Brook PHE
Street
Postcode,City
Country/Region
Title/Position
Tel, (Home\ork)

Fax / E-mail

[ K l [ Cancel ] [ Help ] [ Back

Figure 2. Filling in user data

General options
The options on the OpenOffice.org - General page are described below.

Help
Tips
Extended tips
Help Agent

Reset Help Agent

Help formatting Default w

Open/fSave dialogues
LIse OpenOffice.org dialogues

Document status
[ ] Printing sets "document modified” status

Year (two digits)
Interpret as years between 1930 - and 2029

Figure 3. Setting general options for OpenOffice.org

Help - Tips
When Tips is active, one or two words will appear when you hold the
mouse pointer over an icon or field, without clicking.

Help - Extended tips
When Extended tips is active, a brief description of the function of a
particular icon or menu command or a field on a dialog box appears
when you hold the mouse pointer over that item.
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Help Agent
To turn off the Help Agent (similar to Microsoft’s Office Assistant),
deselect this option. To restore the default behavior, click Reset
Help Agent.

Help formatting
High contrast is an operating system setting that changes the
system color scheme to improve readability. To display Help in high
contrast (if your computer’s operating system supports this), choose
one of the high-contrast style sheets from the pull-down list.

High-contrast style Visual effect

Default Black text on white background
High Contrast #1 Yellow text on black background
High Contrast #2 Green text on black background
High Contrast Black White text on black background
High Contrast White Black text on white background

Open/Save dialogs
To use the standard Open and Save dialog boxes for your operating
system, deselect the Use OpenOffice.org dialogs option. When
this option is selected, the Open and Save dialog boxes supplied with
OpenOffice.org will be used. This book uses the OO0 Open and Save
dialog boxes in illustrations.

Document status
If this option is selected, then the next time you close the document
after printing, the print date is recorded in the document properties
as a change and you will be prompted to save the document again,
even if you did not make any other changes.

Year (two digits)
Specifies how two-digit years are interpreted. For example, if the
two-digit year is set to 1930, and you enter a date of 1/1/30 or later
into your document, the date is interpreted as 1/1/1930 or later. An
“earlier” date is interpreted as being in the following century; that
is, 1/1/20 is interpreted as 1/1/2020.
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Memory options

In the Options dialog, click OpenOffice.org > Memory. Some
considerations:

More memory can make OpenOffice.org faster and more
convenient (for example, more undo steps require more memory);
but the trade-off is less memory available for other applications
and you could run out of memory altogether.

If your documents contain a lot of objects such as images, or the
objects are large, OO0’s performance may improve if you increase
the memory for OOo or the memory per object. If you find that
objects seem to disappear from a document that contains a lot of
them, increase the number of objects in the cache. (The objects
are still in the file even if you cannot see them on screen.)

To load the Quickstarter (an icon on the desktop or in the system
tray) when you start your computer, select the option near the
bottom of the dialog. This makes OpenOffice.org start faster; the
trade-off is OO0 uses some memory even when not being used.
This option (sometimes called Enable systray quickstarter) is
not available on all operating systems.

Undo

Mumber of steps 100 &
Graphics cache
Lise for OpenOffice.org g *. MB
Memory per object 2.4 =i MB
Remove from memory after 00:10 2 hh:mm
Cache for inserted objects
Mumber of objects 20 3

OpenOffice.org Quickstarter
Load OpenOffice.org during system start-up

Figure 4: Choosing Memory options for the OpenOffice.org
applications

View options

The options on the OpenOffice.org - View page affect the way the
document window looks and behaves. Some of these options are
described below. Set them to suit your personal preferences.
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Iser Interface Graphics oukput

Scaling 100% = Use hardware acceleration
Icon size and style Use Anti-Aliasing
Small w || | Galaxy (defadlt) | Mouse
Use system Fonk For user inkerface Mouse positioning
Mo autaratic positioning A
Menu

Middle mouse butkon
Icons in menus

p ; : Autornatic scrolling w
BAutomatic I v

Font Lists Selection
[ ] show preview of Fonts Transparency 5% =
Show Font history

Figure 5: Choosing View options for OpenOffice.org applications

User Interface - Scaling
If the text in the help files or on the menus of the OO0 user interface
is too small or too large, you can change it by specifying a scaling
factor. Sometimes a change here can have unexpected results,
depending on the screen fonts available on your system. However, it
does not affect the font size of the text in your documents.

User Interface - Icon size and style
The first box specifies the display size of toolbar icons (Automatic,
Small, or Large); the Automatic icon size option uses the setting
for your operating system. The second box specifies the icon style
(theme); here the Automatic option uses an icon set compatible
with your operating system and choice of desktop: for example, KDE
or Gnome on Linux.

User Interface - Use system font for user interface
If you prefer to use the system font (the default font for your
computer and operating system) instead of the font provided by OOo
for the user interface, select this option.

User interface - Screen font antialiasing
(Not available in Windows; not shown in Figure 5.) Smooths the
screen appearance of text. Enter the smallest font size to apply
antialiasing.

Menu - Show icons in menus
Causes icons as well as words to be visible in menus.

Choosing options that affect all of OOo 9



Font Lists - Show preview of fonts
Causes the font list to look like Figure 6, Left, with the font names
shown as an example of the font; with the option deselected, the font
list shows only the font names, not their formatting (Figure 6,
Right). The fonts you will see listed are those that are installed on
your system.

Bitstream Vera Sans| 11 v B | Bitstream Vera Sans]| 11
AlAral =0 Arial ~
- Arial Black
AIA_"aI Black Arial Narrow
AlArial Narrow Arial Unicode M3
AlAvaniGarde Bk BT Autumn
AtAvantGarde Md BT s
. Bitztream Yera Sans Mono
Al BakerSienet BT A Bitstream Vera Serif w

Figure 6. Font list (Left) showing preview; (Right) without preview

Font Lists - Show font history
Causes the last five fonts you have assigned to the current document
are displayed at the top of the font list.

Graphics output — Use hardware acceleration
Directly accesses hardware features of the graphical display adapter
to improve the screen display. Not supported on all operating
systems and OOo distributions.

Graphics output — Use anti-aliasing
Enables and disables anti-aliasing, which makes the display of most
graphical objects look smoother and with fewer artifacts. Not
supported on all operating systems and OOo distributions.

Press Shift+Control+R to restore or refresh the view of the

Tip current document.

Mouse positioning
Specifies if and how the mouse pointer will be positioned in newly
opened dialog boxes.

Middle mouse button
Defines the function of the middle mouse button.

« Automatic scrolling - dragging while pressing the middle
mouse button shifts the view.

- Paste clipboard - pressing the middle mouse button inserts the
contents of the “Selection clipboard” at the cursor position.
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The “Selection clipboard” is independent of the normal clipboard
that you use by Edit > Copy/Cut/Paste or their respective
keyboard shortcuts. Clipboard and “Selection clipboard” can contain
different contents at the same time.

Function Clipboard Selection clipboard

Copy content Edit > Copy Select text, table, or object.
Control+C

Paste content Edit > Paste Clicking the middle mouse
Control+V pastes at button pastes at the mouse
the cursor position. pointer position.

Pasting into No effect on the The last marked selection is

another document clipboard contents. the content of the selection

clipboard.

Print options

On the OpenOffice.org - Print page, set the print options to suit your
default printer and your most common printing method.

In the Printer warnings section near the bottom of the page (Figure 7),
you can choose whether to be warned if the paper size or orientation
specified in your document does not match the paper size or
orientation available for your printer. Having these warnings turned on
can be quite helpful, particularly if you work with documents produced
by people in other countries where the standard paper size is different
from yours.

If your printouts are incorrectly placed on the page or chopped
Tip off at the top, bottom, or sides or the printer is refusing to
print, the most likely cause is page-size incompatibility.

Choosing options that affect all of OOo 11



Reduce print data

Settings for (¥} Printer ) Print to file
Printer
[ ] Reduce transparency [ ] Reduce gradients
[ ] reduce bitmaps [ ] Convert colours to greyscale

Printer warnings
Paper size Transparency
Paper orientation

Figure 7. Choosing general printing options to apply to
all OOo components

Path options

On the OpenOffice.org - Paths page, you can change the location of
files associated with, or used by, OOo to suit your working situation. In
a Windows system, for example, you might want to store documents by
default somewhere other than My Documents.

To make changes, select an item in the list shown in Figure 8 and click
Edit. On the Select Paths dialog (not shown), add or delete folders as
required, and then click OK to return to the Options dialog. Note that
many items can have at least two paths listed: one to a shared folder
(which might be on a network) and one to a user-specific folder
(normally on the user’s personal computer).

You can use the entries in the OpenOffice.org - Paths dialog to
Tip compile a list of files, such as those containing AutoText, that
you need to back up or copy to another computer.
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Paths used by Cpencffice.org

Type |Path

AutoCorrect /homefjeanw eberf.opencffice.orgf3juserjautocorr

AutoText fhomefjeanw eberf.openaffice.orgf3fuserfautotext

Backups Jhomefjeanweber/.openoffice.org/3juser/backup

Gallery /homefjeanw eberf.openaffice.orgf3fuser/gallery

Graphics /homefjeanw eberf.openaffice.arg/3fuser/gallery

My Docurments /homefjeanw eber/Docurments

Templates /homefjeanw eberf.openaffice arg/3fuserjfternplate

Temporary files Jtmp

3 3
Default: [ Edit...

Figure 8. Viewing the paths of files used by OOo

Color options

On the OpenOffice.org - Colors page (Figure 9), you can specify colors
to use in OO0 documents. You can select a color from a color table, edit
an existing color, or define new colors. These colors will then be
available in color selection palettes in OOo.

Properties
HEREREEEREN -~
EN N Ree v
HER R (153 [#
SEEESEEE @ = -

HEEETEEEn
EEEEENNC
aEnE

_ 1 |
]

HERNN v

Figure 9. Defining colors to use in color palettes in OO0

255

W

|m

To modify a color:
1) Select the color to modify from the list or the color table.

2) Enter the new values that define the color. If necessary, change
the settings from RGB (Red, Green, Blue) to CMYK (Cyan,
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Magenta, Yellow, Black) or vice versa. The changed color appears
in the lower of the two color preview boxes at the top.

3) Modify the Name as required.

4) Click the Modify button. The newly defined color is now listed in
the Color table.

Alternatively, click the Edit button to open the Color dialog, shown in
Figure 10. Here you can select a color from one of the color windows
in the upper area, or you can enter values in the lower area using your
choice of RGB, CMYK, or HSB (Hue, Saturation and Brightness) values.

The upper right color window is linked directly with the color input
fields in the lower area; as you choose a color in the upper window, the
numbers change accordingly. The two color fields at the lower right
show the value of the selected color on the left and the currently set
value from the color value fields on the right.

Modify the color components as required and click OK to exit the
dialog. The newly defined color now appears in the lower of the color
preview boxes shown in Figure 1. Type a name for this color in the
Name box, then click the Add button. A small box showing the new
color is added to the Color table.

L

Cancel |

Help l

Cyan 40 % =

Magenta 20% | Red 153 || Hue 20 =
Yellow 0% |+ Green 04 2| Saturation 0 [=
Key 0% [z Blue 255 (5| Brightness (100 %

Figure 10: Editing colors

Another way to define or alter colors is through the Colors page of the
Area dialog, where you can also save and load palettes, a feature that
is not possible here. In Calc, draw a temporary draw object and use the
context menu of this object to open the Area dialog. If you load a
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palette in one component of OOo, it is only active in that component;
the other components keep their own palettes.

Font options

You can define replacements for any fonts that might appear in your
documents. If you receive from someone else a document containing
fonts that you do not have on your system, OOo will substitute fonts for
those it does not find. You might prefer to specify a different font from
the one the program chooses.

On the OpenOffice.org - Fonts page (Figure 11):

1) Select Apply Replacement Table option.

2) Select or type the name of the font to be replaced in the Font box.
(If you do not have this font on your system, it will not appear in
the drop-down list in this box, so you need to type it in.)

3) In the Replace With box, select a suitable font from the drop-
down list of fonts installed on your computer.

4) The check mark to the right of the Replace with box turns green.
Click on this check mark. A row of information now appears in the
larger box below the input boxes. Select the boxes under Always
and Screen.

5) In the bottom section of the page, you can change the typeface
and size of the font used to display source code such as HTML
and Basic (in macros).

Apply replacement table
Font Replace with
Helvetica | | Arial » %
Always Screen | Font Replace with |
........... W ¥ Helvetica Arial ~
L

Font settings for HTML and Basic sources
Fonts Automatic il

Mon-proportional fonts anly
Size 10 b

Figure 11. Defining a font to be substituted for another font
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Security options

Use the OpenOffice.org - Security page (Figure 12) to choose security
options for saving documents and for opening documents that contain
macros.

Security options and warnings

Adjust security related options and define warnings For hidden
inFormation in documents, Q_ptlnns

Passwords far web connections

[ ] Persistently save passwords For web connections :
Connections, ..

Praotected by a master password (recommended)
Passwiords are prokected by a master password, You will be asked bo

enter it once per session, if OOo-deyw retrieves a password From the
protected password lisk,

Masker Passwaord, .,

Macro security

Adjust the security level for executing macros and specify trusted macro [ Macro Security. .. ]
developers,

File sharing opkions Far this document
[ ] open this docurment in read-only mode

[ | Record changes [ Prakect, .., ]

Figure 12. Choosing security options for opening and
saving documents

Security Options and warnings
If you record changes, save multiple versions, or include hidden
information or notes in your documents, and you do not want some
of the recipients to see that information, you can set warnings to
remind you to remove it, or you can have OOo remove some of it
automatically. Note that (unless removed) much of this information
is retained in a file whether the file is in OpenOffice.org’s default
OpenDocument format, or has been saved to other formats,
including PDF.

Click the Options button to open a separate dialog with specific
choices (Figure 15).

Remove personal information on saving. Select this option to
always remove user data from the file properties when saving the
file. To manually remove personal information from specific
documents, deselect this option and then use the Delete button
under File > Properties > General.
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L Sy

Security options and warnings

Security warnings

Warn if document contains recorded changes, versions, hidden information or notes:

[]When saving or sending: When signing

[ ] when printing [ ] when creating PDF files

Security options

| Remove personal information on saving
[ ] Recommend password protection on saving

Ctrl-click required to follow hyperlinks

(o J[ o ) [ s ]

Figure 13: Security options and warnings dialog box

Ctrl-click required to follow hyperlinks. In older versions of
OOo, clicking on a hyperlink in a document opened the linked
document. Now you can choose whether to keep this behavior (by
unchecking this box). Many people find creation and editing of
documents easier when accidental clicks on links do not activate the
links.

The other options on this dialog should be self-explanatory.

Macro security
Click the Macro Security button to open the Macro Security dialog,
where you can adjust the security level for executing macros and
specify trusted sources.

File sharing options for this document
Select the Open this document in read-only mode option to
restrict this document to be opened in read-only mode only. This
option protects the document against accidental changes. It is still
possible to edit a copy of the document and save that copy with the
same name as the original.

Select the Record changes option to enable recording changes.
This is the same as Edit > Changes > Record. To allow other users
of this document to apply changes, but prevent them from disabling
change recording, click the Protect button and enter a password.

Choosing options that affect all of OOo 17



Appearance options

Writing, editing, and (especially) page layout are often easier when you
can see the page margins (text boundaries), the boundaries of tables
and sections, grid lines, and other features. In addition, you might
prefer to use colors that are different from OOo0’s defaults for such
items as note indicators or field shadings.

On the OpenOffice.org - Appearance page (Figure 14), you can specify
which items are visible and the colors used to display various items.

« To show or hide items such as text boundaries, select or deselect
them.

« To change the default colors for items, click the down-arrow in
the Color setting column by the name of the item and select a
color from the pop-up box.

« To save your color changes as a color scheme, type a name in the
Scheme box and click Save.

Colour scheme
Scheme OpenOffice.org b
Custom colours
On |User interface elements |Colour setting |Preview |
Document badkground [ automatic [+ i
Text boundaries [ automatic | w I:I
Application background [ Automatic |+ -
Object boundaries [ Automatic |+ I:I
Table boundaries [ automatic | |:|
Font colour [ automatic | -
Unisited links [ automatic | -
Visited links R
AntnEnallimarhac — . [

Figure 14. Showing or hiding text, object, and table
boundaries
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Choosing options for loading and saving
documents

You can set the Load/Save options to suit the way you work.

If the Options dialog is not already open, click Tools > Options. Click
the + sign to the left of Load/Save.

-

Options - Load/Save

OpenOffice.org
B Load/save: [
-:;'Eneral Z_Eﬂ Load/Save
VBA Properties
Microsoft Office
HTML Compatibility This is where you define general settings for opening and sa»

Figure 15: Load/Save options

General Load/Save options

Most of the choices on the Load/Save - General page (Figure 16) are
familiar to users of other office suites. Some items of interest are
described below.

Load
Load user-specific settings with the document

Load printer settings with the document
Save

[] Edit document properties befare saving
Always create backup copy
Save AutoRecovery information every m Minutes
Save URLs relative to file system
Save URLs relative to internet
Default file format and ODF settings
ODF format wersion 1.2 (recommended)] e

Size optimization for ODF format

[] warn when not saving in ODF or default format
Document type Always save as

Text document v ODF Text Document e

Figure 16. Choosing Load and Save options

Load user-specific settings with the document
When you save a document, certain settings are saved with it. Some
settings (printer name, data source linked to the document) are
always loaded with a document, whether or not this option is
selected. If you select this option, these document settings are
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overruled by the user-specific settings of the person who opens it. If
you deselect this option, the user’s personal settings do not overrule
the settings in the document. For example, your choice (in the
options for OO0 Writer) of how to update links is affected by the
Load user-specific settings option.

Load printer settings with the document
If this option is not selected, the printer settings that are stored
with the document are ignored when you print it using the Print
File Directly icon. The default printer in your system is used
instead.

Edit document properties before saving
If this option is selected, the Document Properties dialog pops up to
prompt you to enter relevant information the first time you save a
new document (or whenever you use Save As).

Save AutoRecovery information every __ Minutes
Choose whether to enable AutoRecovery and how often to save the
information used by the AutoRecovery process.

AutoRecovery in OpenOffice.org overwrites the original file. If you
also choose Always create backup copy, the original file then
overwrites the backup copy. If you have this option set, recovering
your document after a system crash will be easier; but recovering an
earlier version of the document may be harder.

Save URLs relative to file system / internet
Relative addressing to a file system is only possible if the source
document and the referenced document are both on the same drive.
A relative address always starts from the directory in which the
current document is located. It is recommended to save relatively if
you want to create a directory structure on an Internet server.

Default file format and ODF settings
ODF format version. OpenOffice.org by default saves documents in
Open Document Format (ODF) version 1.2. While this allows for
improved functionality, there may be backwards compatibility
issues. When a file saved in ODF 1.2 is opened in an earlier version
of OpenOffice.org (using ODF 1.0/1.1), some of the advanced
features may be lost. Two notable examples are cross-references to
headings and the formatting of numbered lists. If you plan to share
documents with people who are still using older versions of
OpenOffice.org, save the document using ODF version 1.0/1.1.
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Size optimization for ODF format. OpenOffice.org documents are
XML files. When you select this option, OO0 writes the XML data
without indents and line breaks. If you want to be able to read the
XML files in a text editor in a structured form, deselect this option.

Document type. If you routinely share documents with users of
Microsoft Word, you might want to change the Always save as
attribute for text documents to one of the Word formats.

Although Writer can open files in the .docx format produced by
Note Word 2007, it cannot save in .docx format. This capability is
planned for a future release.

VBA Properties Load/Save options

On the Load/Save - VBA Properties page (Figure 17), you can choose
whether to keep any macros in Microsoft Office documents that are
opened in OpenOffice.org.

« If you choose Save original Basic code, the macros will not
work in OOo but are retained if you save the file into Microsoft
Office format.

« If you choose Load Basic code to edit, the changed code is
saved in an OOo document but is not retained if you save into a
Microsoft Office format.

« If you are importing a Microsoft Excel file containing VBA code,
you can select the option Executable code. Whereas normally
the code is preserved but rendered inactive (if you inspect it with
the StarBasic IDE you will notice that it is all commented), with
this option the code is ready to be executed.

Microsoft Weord 97/2000/XP
Load Basic code

Save original Basic code

Microsoft Excel 97/2000/XP
Load Basic code

[] Executable code
Save original Basic code

Microsoft PowerPoint 97/2000/XP
Load Basic code

Save original Basic code

Figure 17: Choosing
Load/Save VBA Properties
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Microsoft Office Load/Save options

On the Load/Save - Microsoft Office page (Figure 18), you can choose
what to do when importing and exporting Microsoft Office OLE objects
(linked or embedded objects or documents such as spreadsheets or
equations).

Select the [L] check boxes to convert Microsoft OLE objects into the
corresponding OpenOffice.org OLE objects when a Microsoft document
is loaded into OO0 (mnemonic: “L’” for “load”).

Select the [S] check boxes to convert OpenOffice.org OLE objects into
the corresponding Microsoft OLE objects when a document is saved in
a Microsoft format (mnemonic: “S” for “save”).

|1 | ©& |
I ™ MathsType to OpenOffice.org Maths / OpenOffice. org Maths to MathsType e
r WinWord to OpenOffice. org Writer / OpenOffice.org Writer to WinWord
r [T Excel to OpenCffice.org Calc / OpenOffice.org Calc to Excel
r PowerPoint to OpenCffice.org Impress / QpenCffice.org Impress to PowerPoint

[L]: Load and convert the object

[5]: Convert and save the object

Figure 18. Choosing Load/Save Microsoft Office options

HTML compatibility Load/Save options

Choices made on the Load/Save - HTML Compatibility page

(Figure 19) affect HTML pages imported into OpenOffice.org and those
exported from OOo. See HTML documents; importing/exporting in the
Help for more information.
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Forit sizes Imipart
Size 1 7 - [] Use 'English (USA}' locale for numbers
Size 2 10 ~ [ ] Import unknown HTML tags as fields
= w
[] gnore font settings
Size 3 12 B
Export
Size 4 14 &
Metscape Mavigator b
Size 5 18 £
[ ] OpenOffice.org Basic
Size 24 &
- = Display warning
: -~ e
2=l 36 > [1 Print layout
Copy local graphics to Internet
Character set Western Europe (Windows-12] %

Figure 19. Choosing HTML compatibility options

Font sizes
Use these fields to define the respective font sizes for the HTML
<font size=1> to <font size=7> tags, if they are used in the HTML
pages. (Many pages no longer use these tags.)

Import - Use 'English (USA)' locale for numbers
When importing numbers from an HTML page, the decimal and
thousands separator characters differ according to the locale of the
HTML page. The clipboard, however, contains no information about
the locale. If this option is not selected, numbers will be interpreted
according to the Language - Locale setting in Tools > Options >
Language Settings > Languages (see page 36). If this option is
selected, numbers will be interpreted as for the English (USA)
locale.

Import - Import unknown HTML tags as fields
Select this option if you want tags that are not recognized by OOo to
be imported as fields. For an opening tag, an HTML ON field will be
created with the value of the tag name. For a closing tag, an
HTML OFF will be created. These fields will be converted to tags in
the HTML export.

Import - Ignore font settings
Select this option to have OOo ignore all font settings when
importing. The fonts that were defined in the HTML Page Style will
be used.
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Export
To optimize the HTML export, select a browser or HTML standard
from the Export box. If OpenOffice.org Writer is selected, specific
OpenOffice.org Writer instructions are exported.

Export - OpenOffice.org Basic
Select this option to include OO0 Basic macros (scripts) when
exporting to HTML format. You must activate this option before you
create the OpenOffice.org Basic macro; otherwise the script will not
be inserted. OpenOffice.org Basic macros must be located in the
header of the HTML document. Once you have created the macro in
the OpenOffice.org Basic IDE, it appears in the source text of the
HTML document in the header.

If you want the macro to run automatically when the HTML
document is opened, choose Tools > Customize > Events. See
Chapter 13 (Getting Started with Macros) in the Getting Started
guide for more information.

Export - Display warning
When the OpenOffice.org Basic option (see above) is not selected,
the Display warning option becomes available. If the Display
warning option is selected, then when exporting to HTML a
warning is shown that OpenOffice.org Basic macros will be lost.

Export - Print layout
Select this option to export the print layout of the current document
as well.

The HTML filter supports CSS2 (Cascading Style Sheets Level 2) for
printing documents. These capabilities are only effective if print
layout export is activated.

Export - Copy local graphics to Internet
Select this option to automatically upload the embedded pictures to
the Internet server when uploading using FTP.

Export - Character set
Select the appropriate character set for the export.
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Choosing options for Writer

Settings chosen on the pages in the OpenOffice.org Writer section of
the Options dialog box determine how your Writer documents look and
behave while you are working on them.

If the Options dialog box is not already open, click Tools > Options.

Click the + sign by OpenOffice.org Writer on the left-hand side of the
Options - OpenOffice.org dialog box. A list of pages drops down.

FE Options - OpenOffice.org Writer

OpenOffice.org —
Load/Save o ;
i s g’ OpenOffice.org Writer
|[OpenCtfice. org W riter]
General

O HEE

View This is where vou specify various settings for text ¢
Formatting Aids determine how your text documents are handled in
Grid for all new OpenOffice.org Writer documents. You ¢
Basic Fonts (Western) for the active text document if vou save it afterwar
Print

Table

Changes

Compatibility

AutoCaption

Mail Merge E mall
# OpenOffice.org W eb
+ OnenOffic

Figure 20: O}ﬁenOffzce org Writer options

General options

The choices on the OpenOffice.org Writer - General page (Figure 21)
affect the updating of links and fields, the units used for rulers and
other measurements, and the default tab stop positions.

Update links when loading
Depending on your work patterns, you may not want links to be
updated when you load a document. For example, if your file links to
other files on a network, you won’t want those links to update when
you are not connected to the network.

Update fields and charts automatically
You may not want fields or charts to update automatically when you
are working, because that slows down performance.
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Update
Update links when loading Automatically
() Always Fields
{(*) On reguest Charts
) Mever
Settings
Measurement unit inch W
Tab stops 0.50" i

Figure 21. Choosing general options for Writer

Settings - Tab stops

The Tab stops setting specifies the distance the cursor travels for
each press of the Tab key. This setting is also used for the indent
distance applied by the Increase Indent and Decrease Indent
buttons on the Formatting Bar, which affect the indentation of
entire paragraphs.

Using the default tab stops to space out or indent material on a page
is not recommended. If you use the default tab interval and then
send the document to someone who uses a different default tab
interval, then your tabbed material will be displayed using the other
person’s default tab settings. In addition, any changes to the default
tab stops will change the existing default tab stops in any document
you open afterward, as well as tab stops you insert after making the
change.

To avoid these unwanted changes, define your own tabs in
paragraph styles or individual paragraphs (see “Defining your own
tab stops and indents” in Chapter 3).

View options

Two pages of options set the defaults for viewing Writer documents:
View (described here) and Formatting Aids (described in the next
section).

If the items on the OpenOffice.org Writer - View page (Figure 22) are
not self-explanatory, you can easily test their effects in a blank
document.

This is a good page to check if, for example, you cannot see graphics
on the screen or you see field codes instead of the text or numbers you
are expecting.
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Guides View
[ ] Guides while moving Horizontal scrollbar
Simple handles Vertical scrollbar
[ ] Large handles Ruler
Display Horizontal ruler inch
Graphics and objects Vertical ruler inch
Tables [ ] smooth scroll
Drawings and controls
[ ] Field codes
Motes

Figure 22. Choosing View options for Writer

Formatting Aids options

The display of symbols such as paragraph ends and tabs help you when

writing, editing, and doing page layout. For example, you might want

to know if any blank paragraphs or tabs are included or if any tables or

graphics are too wide and intrude into the margins of the page.
On the OpenOffice.org Writer - Formatting Aids page (Figure 23),

select the required options.

Display of Direct cursor
Paragraph end [ ] pirect cursor
Custom hyphens Insert
Spaces {*) Paragraph alignment
Mon-breaking spaces () Left paragraph margin
Tabs () Tabs
Breaks {_) Tabs and spaces
Hidden text Cursor in protected areas
[ Fields: Hidden text Enable
[ ] Fields: Hidden paragraphs

Figure 23. Choosing Formatting Aids options

Direct cursor lets you enter text, images, tables, frames, and

other objects in any blank area in your document. Writer inserts

blank paragraphs and tabs to position the text or objects.

This feature is incompatible with rigorous use of styles and can
lead to many formatting oddities, so it should be avoided by

Note

professional writers.

Choosing options for Writer
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Grid options

Specifying “snap to grid” can be very helpful when you are trying to
align several objects such as graphics or tables.

On the OpenOffice.org Writer - Grid page (Figure 24), you can choose
whether to enable this feature and what grid intervals to use. If the
grid intervals (subdivisions) are too large, you may find that you do not
have enough control in placing the objects.

Grid
[ ] snap to grid
[ ] visible grid

Resolution Subdivision
Horizontal 0,407 s Horizontal 1 2| point(s)
Vertical 0,407 s .| point(s)

Synchronise axes

Vertical 1

Figure 24. Choosing Grid options

Default fonts

The default fonts specified on the OpenOffice.org Writer - Basic Fonts
(Western) page apply to both Writer documents and HTML (Web)
documents.

« If you want to change the defaults, do so on this page (Figure 25).
You can, of course, choose other fonts for use in specific
documents, either by applying direct formatting or by defining
and applying styles in those documents.

« When choosing fonts on this page you are not limited to single
fonts or to the ones shown in the drop-down list. You can specify a
“font family”as a comma-separated set of fonts that includes those
suitable for Windows, Macintosh, Linux, and other operating
systems. These choices are particularly important in HTML
documents.

« If the document is viewed on a system that does not have the first
font specified, it will use one of the other fonts if that one is
available. Otherwise, it will substitute a font that is available on
the system.

« Type the list of fonts, separated by commas, in the boxes. If you
want these defaults to apply to the current document only, select
that option. The Default button resets the values on this page to
the defaults installed with OpenOffice.org.
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Basic fonts (Western)
Font Size

Default Times Mew Roman W |12 »
Heading Arial v (14 |w
List Times Mew Roman w( |12 a
Caption Times MNew F.oman w| |12 w
Index Times New Roman | 12 b

[ ] current document only

Figure 25. Choosing default fonts

Print options

On the OpenOffice.org Writer - Print page (Figure 26), you can choose
which items are printed with the document by default. These options
are in addition to those on the OpenOffice.org - Print page (Figure 7).

Some considerations:

When you are working on drafts and you want to save printer ink
or toner, you might want to deselect some of the items in the
Contents section.

The Print black selection causes color text (but not graphics) to
print as black on a color printer; on a black-and-white printer, this
option causes color text to print as solid black instead of shades
of grey (dithered).

Contrast Print black with Convert colors to greyscale on the
Options - OpenOffice.org - Print page (Figure 7), which prints all
graphics as greyscale on color printers. (On black-and-white
printers, color in graphics normally prints as greyscale.)

If you are printing double-sided on a non-duplexing printer, you
might choose to print only left or right pages, then turn the stack
over and print the other pages.

Depending on how your printer ejects pages (face up or face
down), you might need to print the pages in reverse order so they
stack in the correct order as they are printed.
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You can override any of these defaults when printing a
document. Click File > Print, then click the Options button

Tip on the Print dialog box. The Printer Options dialog box that
appears is similar to the one shown in Figure 26.
Contents Pages Comments
Graphics Left pages (# None
Tables Right pages {3 Comments only
Drawings [] Reversed (" End of document
Controls ] Brochure {7 End of page

Background
[] Print black
[] Hidden text
[[] Text placeholder

Other
Print automatically inserted blank pages
[] create single print jobs
[[] Paper tray from printer settings

Fax =Mone=

Figure 26. Choosing Print options for Writer

Default table options

On the OpenOffice.org Writer - Table page (Figure 27), you can specify

the default behavior of tables.

Default Input in tables
Heading Mumber recognition
Fepeat on each page! Mumber format
[ ] Do not split Alignment
Border
Keyboard handling
Move cells Insert cell
Row 0,20 i Fow
Column 0.20° x Column

Behaviour of rowsfcolumns
) Eixed

) Fixed, proportional Changes affect the entire table

{*) Variable Changes affect the table size

Changes affect the adjacent area only

recognition

0.20"

W

100"

W

Figure 27. Choosing default Table options
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Some considerations:

« If most of your tables will require borders or headings, select
those options. If most of your tables are used for page layout,
deselect borders and headings.

« Number recognition can be very useful if most of your tables
contain numerical data; Writer will recognize dates or currency,
for example, and format the numbers appropriately. However, if
you want the numbers to remain as ordinary text, this feature can
be quite irritating, so you will want to deselect it.

« The Keyboard handling section specifies the distances that cells
move when you use keyboard shortcuts to move them and the size
of rows and columns inserted using keyboard shortcuts.

« The choices in the Behavior of rows/columns section determine
the effects that changes to rows or columns have on adjacent
rows or columns and the entire table. You might need to test
these selections to fully understand the effects.

Change tracking options

If you plan to use the change-tracking feature of Writer, use the
OpenOffice.org Writer - Changes page (Figure 28) to choose the way
inserted and deleted material is marked, whether and how attribute
changes are marked, and whether and how change bars are marked in
the margins.

Text display
Insertions
Attributes IUnderlined
[nsert |
Colour By author —_—
Deletions
Attributes Strikethrough b B ] |
Colour By authar w
Changed attributes
Attributes Bold L .
Attributes]
Colour By authar bl
Lines changed
Mark Left margin
Colour I Light red w — tl=

Figure 28. Choosing options for tracking changes
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Compatibility options

Do you need to import Microsoft Word documents into OOo Writer? If
so, you might want to select some or all of the settings on the
OpenOffice.org Writer - Compatibility page (Figure 29). If you are not
sure about the effects of these settings, leave them as the defaults
provided by OOo. For information about the settings not described

below, see the Help.

Compatibility options for 0202WG-SettingUpWriter_PHB_20070918
Options

| Use printer metrics for document formatting
[w add spacing between paragraphs and tables {in current document)

Add paragraph and table spacing at tops of pages (in current document)
[ Use Openoffice.org 1.1 tab stop formatting
[w Do not add leading {extra space) between lines of text
[ LUse Openoffice.org 1.1 line spacing
[ add paragraph and table spacing at bottom of table cells
[w Use OpenOffice.org 1.1 ohiject positioning
[ Use OpenOffice.org 1.1 text wrapping around objects
Consider wrapping style when positioning objects
[~ Expand word space on lines with manual line breaks in justified paragraphs

[ IUse as Default

Figure 29. Choosing compatibility options

Use printer metrics for document formatting

If this option is selected, the printer specified for the document
determines how the document is formatted for viewing on screen.
The line breaks and paragraph breaks you see on screen match
those that apply when the document is printed on that printer.

This setting can be useful when several people are reviewing a
document that will eventually be printed on a specific printer or
when the document is exported to PDF (a process that uses “Adobe

PDF” as the printer).

If this option is not selected, a printer-independent layout will be

used for screen display and printing.

Add spacing between paragraphs and tables (in current

document)

In OpenOffice.org Writer, paragraph spacing is defined differently
than it is in MS Word documents. If you have defined spacing
between two paragraphs or tables, spacing is also added in the

corresponding MS Word documents.
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If this option is selected, MS Word-compatible spacing is added
between paragraphs and tables in OpenOffice.org Writer documents.

Add paragraph and table spacing at tops of pages (in current
document)
You can define paragraphs to have space appear before (above)
them. If this option is selected, any space above a paragraph will
also appear if the paragraph is at the beginning of a page or column,
if the paragraph is positioned on the first page of the document, or
after a manual page break.

If you import an MS Word document, the spaces are automatically
added during the conversion.

Add paragraph and table spacing at bottom of table cells
Specifies that the bottom spacing is added to a paragraph, even
when it is the last paragraph in a table cell.

Use as Default
Click this button to use the current settings on this page as the
default in OpenOffice.org.

AutoCaption options

Do you want OOo to automatically insert captions for tables, pictures,
frames, and OLE objects that have been inserted in a Writer
document?

You may not always want captions for every table, for example,
if you use tables for layout as well as for tables of data. You
can always add captions to individual tables, graphics, or other
objects (right-click > Caption).

Note

If you do want automatic captions on one or more object types:

1) Choose OpenOffice.org Writer > AutoCaption on the Options
dialog box.

2) On the OpenOffice.org Writer - AutoCaption page (Figure 30),
select the check box next to an object you want to be
automatically captioned (Picture in the example shown).

3) With the item highlighted, specify the characteristics of the
caption. The supplied categories for captions are Drawing,
Illustration, Table, and Text. However, you are not limited to the
supplied categories. If you want to use another name (for
example, Figure) for the caption label, type the required term in
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the box. In the example shown, I have added the category
“Figure” to the list.

Additional information about numbering captions by chapter, character
styles, frame styles, and other items on the AutoCaption page, is given
in later chapters in the Writer Guide.

Add captions automatically Caption

when inserting: Category

[ OpenOffice.org Writer Table Mumbering Arabic {12 3) w
OpenQffice, org Writer Frame

[v OpenOffice.org Writer Picture Separator

[~ CpenOffice. org Spreadsheet -

[ Openoffice.org Chart Position Belo

|_ OpenOffice.org Drawing

|_ OpenQffice, org Presentation
[ Openoffice.org Formula Level 1 W
[ other OLE Chjects

Mumbering captions by chapter

Separator
Category and frame format
Character style Mone bl

[ ] apply border and shadow

Figure 1:

Figure 30. Setting up a new category for automatic
captions on graphics

Mail Merge E-mail options

You can produce form letters using Writer and then use the mail merge
function to personalize those letters and send them to a number of
addresses taken from a data source, such as an address book. Mail
merged documents can be printed and mailed, or sent by e-mail.

Use the OpenOffice.org Writer - Mail Merge E-mail page (Figure 31) to
set up the user and server information for sending form letters by e-
mail. If you are not sure what information to put in any of the fields,
consult your e-mail program or your Internet service provider.
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Uzer information
Your name
E-Mail address
[] send replies to different e-mail address

Outgoing server (SMTF) Settings
SErver name Port [ 25

[ ] Use secure connection {S5L)

[ Server Authentication ]

[ Test Settings... ]

Figure 31: Specifying settings for use when e-mailing
mail-merged form letters

Choosing options for HTML documents

You can configure OpenOffice.org to treat HTML documents in Writer
differently than regular documents.

1) If the Options dialog box is not already open, click Tools >
Options.

2) Click the + sign by OpenOffice.org Writer/Web on the left-hand
side of the Options - OpenOffice.org dialog box. A list of pages
drops down.

Here you can customize settings related to printing, formatting aids,
view options, table defaults, the grid, and a default background for
HTML documents you're working with in Writer.

Many of the options available under Options - OpenOffice.org
Writer/Web are identical to the settings under Options -

Note OpenOffice.org Writer but will only affect HTML documents
opened in Writer. The previous sections contain detailed
discussion on these options.
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Choosing language settings

You may need to do several things to set the language settings to what
you want:

« Install the required dictionaries
« Change some locale and language settings
« Choose spelling options

Install the required dictionaries

0003 automatically installs several dictionaries with the program. To
add other dictionaries, be sure you are connected to the Internet, and
then use Tools > Language > More Dictionaries Online. OOo will
open your default web browser to a page containing links to additional
dictionaries that you can install. Follow the prompts to select and
install the ones you want.

Change some locale and language settings

You can change some details of the locale and language settings that
OO0Oo uses for all documents or for specific documents.

In the Options dialog box, click Language Settings > Languages.

-

Options - Language Settings

OpenOffice.org
LoadfSave .
E Language Settings:
Languages
Writing Aids
OpenOffice, org Writer This is where you make settings concerning language and »
OpenOffice. org Writer Web OpenOffice.org.

Figure 32: OpenOffice.org language options

'351 Language Settings

On the right-hand side of the Language Settings - Languages page
(Figure 33), change the User interface, Locale setting, Default
currency, and Default languages for documents as required. In the
example, English (UK) has been chosen for all the appropriate settings.

If you want the language (dictionary) setting to apply to the current
document only, instead of being the default for all new documents,
select For the current document only.

If necessary, select the options to enable support for Asian languages
(Chinese, Japanese, Korean) and support for CTL (complex text layout)
languages such as Hindi, Thai, Hebrew, and Arabic. If you choose
either of these options, the next time you open this page, you will see

36 Setting up Writer



some extra pages under Language Settings, as shown in Figure 34.
These pages (Searching in Japanese, Asian Layout, and Complex Text
Layout) are not discussed here.

Language of

Lser interface English {UK) bl
Locale setting English {LIK) W
Decimal separator key Same as locale setting (. )

Default currency GBP £ English (LK) bl

Default languages for documents

Western S8 English (LK) w

[ ] Fer the current document only
Enhanced language support

[ ] Enabled for Asian languages
[ ] Enabled for complex text layout (CTL)

Figure 33. Choosing language options

Options - Language Settings

OpenOffice.org
Load/Sawve

% Language Settings

Languages

Writing Aids

Searching in Japanese This is where you make settings concernin
Asian Layout CipenOffice.org.

Complex Text Layout

Figure 34. Extra pages available when enhanced language
support options are selected

Choose spelling options

To choose the options for checking spelling, click Language Settings
> Writing Aids. In the Options section of the page (Figure 35), choose
the settings that are useful for you. Some considerations:

« If you do not want spelling checked while you type, deselect
Check spelling as you type and select Do not mark errors. (To
find the second item, scroll down in the Options list.)

« If you use a custom dictionary that includes words in all
uppercase and words with numbers (for example, AS/400), select
Check uppercase words and Check words with numbers.
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« Check special regions includes headers, footers, frames, and
tables when checking spelling.

Here you can also check which of the user-defined (custom)
dictionaries are active, or you can add or remove dictionaries by
clicking the New or Delete buttons.

Wy'riting aids
Available language modules

Hurspell SpellChecker [ Edit... ]
Libbphen Hyphenatar —
CpenCffice.org Mew Thesaurus

[]<]<]

—
5]

er-defined dictionaries

| scffice [All] [ Mew. .. ]
| sun [all] —
7] IgniorealList [al] | Edi. |
Dptions

Check spelling as vou type A

Check grammar as vou type

Check uppercase words

Check words with numbers

Check. capitalization .

Pl TIPTI ey Juy Ry puyere

|
|
[

Figure 35. Choosing languages, dictionaries, and
options for checking spelling

OpenOffice.org does not have a grammar checker, but you can
install a grammar checker extension such as Language Tool
and access that tool from Tools > Spelling and Grammar.
See Chapter 14 for more about installing extensions.

Note

Controlling Writer’s AutoCorrect functions

Some people find some or all of the items in Writer’s AutoCorrect
feature annoying because they change what you type when you don’t
want it changed. Many people find some of the AutoCorrect functions
quite helpful; if you do, then select the relevant options. But if you find
unexplained changes appearing in your document, this is a good place
to look to find the cause.

To open the AutoCorrect dialog box, click Tools > AutoCorrect
Options. (You need to have a document open for this menu item to
appear.)

In Writer, this dialog box has five tabs, as shown in Figure 36.
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Replacements and exceptions for language: |E|'u;||is|'| (LK) |

\Replace | Exceptions |0ptiu-ns | Custom Quotes | Word Completion |

M [ |
v v Use replacement table [i
v ¥  Correct Two INitial CApitals
= ¥ capitalise first letter of every sentence
~ v  Automatic *bold®and _underline_
B v URL Recognition
v ¥ Replace ist... with 17st...
~ ¥ Replace 1/2... with 12 .., L
v [¥ Replace dashes 1
B [T Delete spaces and tabs at beginning and end of paragraph
I [T Delete spaces and tabs at end and start of line
[¥  Ignore double spaces
v  Apply numbering - symbal: *
v  apply border “m
¥ Create table
[T apply Styles
r Remove blank paragraphs
"2 Replace Custom Stvles M
- [M]: Replace while modifying existing text
= [T]: AutoFormatfAutoCarrect while typing

[ oK H Cancel H Help ” Reset ]

Figure 36. The AutoCorrect dialog box in Writer, showing
the five tabs and some of the choices on the Options tab

Controlling Writer’s AutoCorrect functions



	Copyright
	Choosing options that affect all of OOo
	User Data options
	General options
	Memory options
	View options
	Print options
	Path options
	Color options
	Font options
	Security options
	Appearance options

	Choosing options for loading and saving documents
	General Load/Save options
	VBA Properties Load/Save options
	Microsoft Office Load/Save options
	HTML compatibility Load/Save options

	Choosing options for Writer
	General options
	View options
	Formatting Aids options
	Grid options
	Default fonts
	Print options
	Default table options
	Change tracking options
	Compatibility options
	AutoCaption options
	Mail Merge E-mail options

	Choosing options for HTML documents
	Choosing language settings
	Install the required dictionaries
	Change some locale and language settings
	Choose spelling options

	Controlling Writer’s AutoCorrect functions

